18°

CVE-2020-5405:Spring-cloud-config-server路径遍历漏洞警报

2月26日,Spring官方发布了Spring Cloud Config中的漏洞通知。NSFOCUS安全研究员yiing Xiang在spring-cloud-config-server组件中发现了一个路径遍历漏洞(CVE-2020-5405)。

攻击者可以利用此漏洞遍历目录并读取未授权文件的内容。恶意用户或攻击者可以使用专门设计的URL发送请求,从而导致目录遍历攻击。用户被要求尽快将spring-cloud-config-server升级到修复后的版本,以防止该漏洞。

受影响版本:

  • Spring Cloud Config 2.2.0 to 2.2.1
  • Spring Cloud Config 2.1.0 to 2.1.6

未受影响版本:

  • Spring Cloud Config 2.2.2
  • Spring Cloud Config 2.1.7

解决方法

Pivotal已在最新的Spring Cloud Config版本中修复了该漏洞,受影响的用户应尽快升级该版本。 开发人员可以通过配置Maven来升级应用程序并进行编译和发布。

原文链接:https://www.linuxidc.com/Linux/2020-03/162540.htm

全部评论: 0

    我有话说: